Nhiều lỗi thực thi mã được tìm thấy trong lập trình PHP

Các nhà bảo trì ngôn ngữ lập trình PHP gần đây đã phát hành các phiên bản PHP mới nhất để vá nhiều lỗ hổng nghiêm trọng cao trong các thư viện lõi và gói, trong đó nghiêm trọng nhất có thể cho phép kẻ tấn công từ xa thực thi mã tùy ý và thỏa hiệp các máy chủ được nhắm mục tiêu.

Bộ xử lý siêu văn bản, thường được gọi là PHP, là ngôn ngữ lập trình web phía máy chủ phổ biến nhất, cung cấp năng lượng cho hơn 78% Internet hiện nay.

Các bản phát hành mới nhất thuộc một số nhánh được bảo trì bao gồm phiên bản PHP 7.3.9, 7.2.22 và 7.1.32, giải quyết nhiều lỗ hổng bảo mật.

Tùy thuộc vào loại, sự xuất hiện và cách sử dụng của cơ sở mã bị ảnh hưởng trong ứng dụng PHP, việc khai thác thành công một số lỗ hổng nghiêm trọng nhất có thể cho phép kẻ tấn công thực thi mã tùy ý trong bối cảnh ứng dụng bị ảnh hưởng có các đặc quyền liên quan.

Nhiều lỗi thực thi mã được tìm thấy trong lập trình PHP

Mặt khác, các nỗ lực khai thác thất bại có thể sẽ dẫn đến tình trạng từ chối dịch vụ (DoS) trên các hệ thống bị ảnh hưởng.

Các lỗ hổng có thể khiến hàng trăm ngàn ứng dụng web dựa trên PHP mở các cuộc tấn công thực thi mã, bao gồm các trang web được cung cấp bởi một số hệ thống quản lý nội dung phổ biến như WordPress, Drupal và Typo3.

Trong số này, lỗ hổng thực thi mã ‘sử dụng sau khi sử dụng’ miễn phí, được gán là CVE-2019-13224, nằm trong Oniguruma, một thư viện biểu thức chính quy phổ biến đi kèm với PHP, cũng như nhiều ngôn ngữ lập trình khác.

Kẻ tấn công từ xa có thể khai thác lỗ hổng này bằng cách chèn một biểu thức chính quy được chế tạo đặc biệt trong một ứng dụng web bị ảnh hưởng, có khả năng dẫn đến thực thi mã hoặc gây lộ thông tin.

Kẻ tấn công cung cấp một cặp mô hình regex và một chuỗi, với mã hóa nhiều byte được xử lý bởi onig_new_deluxe ()“, Red Hat nói trong lời khuyên bảo mật mô tả lỗ hổng này.

Nhiều lỗi thực thi mã được tìm thấy trong lập trình PHP

Các lỗi được vá khác ảnh hưởng đến phần mở rộng curl, chức năng Exif, Trình quản lý quy trình FastCGI (FPM), tính năng Opcache, v.v.

Tin tốt là cho đến nay không có báo cáo về bất kỳ lỗ hổng bảo mật nào đang bị những kẻ tấn công khai thác trong tự nhiên.

Nhóm bảo mật PHP đã giải quyết các lỗ hổng trong các phiên bản mới nhất. Vì vậy, người dùng và nhà cung cấp dịch vụ lưu trữ được khuyến nghị mạnh mẽ nâng cấp máy chủ của họ lên phiên bản PHP mới nhất 7.3.9 , 7.2.22 hoặc 7.1.32 .

Leave a Reply